English

EyeTV 2 software is no longer supported.

Earlier versions of EyeTV software will not work as expected when using OS X 10.8 (Mountain Lion) , OS X 10.9 (Mavericks) or OS X 10.10 (Yosemite).

There will be a number of issues, including activation key problems, permissions issues, preferences not being remembered, and crashing.


Upgrading to EyeTV 3


EyeTV 2 software was last developed in 2008.  The last version was EyeTV 2.5.3.

It was replaced by EyeTV 3, which has been updated many times over the years to add new features, and to support new versions of OS X as they have been released.

The latest version of EyeTV 3 is needed when using recent versions of OS X.

EyeTV 2 users can upgrade to EyeTV 3 for a special, discounted price.  Visit the Elgato Online Store for more details:

https://www.elgato.com/en/online-store

Choose the “EyeTV 3 Upgrade Version”.  You will need your EyeTV 2activation key, or EyeTV 2 already installed on your Mac, to take advantage of this offer.

If you need support regarding your EyeTV product please do not hesitate to contact us following this link.

Contact Support
https://www.geniatech.eu/faq/eyetv-2-will-not-work-as-expected-in-os-x-10-8-and-above/ EyeTV 2 will not work as expected in OS X 10.8 and above